April 2024
M T W T F S S
1234567
891011121314
15161718192021
22232425262728
2930  

Categories

April 2024
M T W T F S S
1234567
891011121314
15161718192021
22232425262728
2930  

Finding the process that locked a port in AIX

Finding the process that locked a port in AIX ******************************************************************** Run the following command to check if port is in use

# netstat -an | grep <port number>

If above returns the connection, then run the following command to get the address of the port number

# netstat -Aan | grep <port number>

Once you […]

AIX : Machine Type & Serial Number

AIX : Machine Type & Serial Number

uname -m for the serial number

uname -M for the machine type and model

AIX PowerHA (HACMP) Commands

Most commands should work on all PowerHA (HACMP prior to 5.5) versions. If there is some syntax error, please consult the manual page for that command.

PowerHA(HACMP) Commands How to start cluster daemons (options in that order: clstrmgr, clsmuxpd, broadcast message, clinfo, cllockd) clstart -m -s -b -i -l How to show cluster state and […]

AIX Install packages, upgrade, patching commands

To see the details of installed file sets:

#lslpp -l

To list the installation history of all file set in bos.net packages:

#lslpp -ha bos.net.*

To list the files in the bos.rte package:

#lslpp -f bos.rte

To list the file set which contain /etc/hosts file:

#lslpp -w /etc/hosts

To list the pre requisites for bos.net.nfs.server […]

Top 12 ‘PS’ Performance Commands

I use following ps commands in order to check for performance probelms:

1) Displaying top CPU_consuming processes:

# ps aux|head -1; ps aux|sort -rn +2|head -10

2) Displaying top 10 memory-consuming processes:

# ps aux|head -1; ps aux|sort -rn +3|head

3) Displaying process in order of being penalized:

# ps -eakl|head -1; ps -eakl|sort […]

TOTAL/USED/AVAILABLE memory in AIX

TOTAL/USED/AVAILABLE memory in AIX

  #!/usr/bin/ksh #memory calculator um=`svmon -G | head -2|tail -1| awk {‘print $3’}` um=`expr $um / 256` tm=`lsattr -El sys0 -a realmem | awk {‘print $2’}` tm=`expr $tm / 1000` fm=`expr $tm – $um` echo “\n\n———————–“; echo “System : (`hostname`)”; echo “———————–\n\n”; echo “Memory Information\n\n”; echo “total memory = $tm MB” […]

Aix commands

Commands

CUT:

lspv | cut -c 6-7 lists the hdisks numbers (cuts the 6th and 7tn character (disk nubers)) dlnkmgr view -drv | grep -w 00000 | awk ‘{print $4}’ | cut -d . -f 3

——————————————————————————–

EXPR: integer arithmetic

\* multiplication (\ is needed to tell * is not a special character) / division […]

ulimit

Resource limits is the concept where you regulate several resources consumed by a process on an UNIX operating systems. Although the resource limits are set on a per user basis, they are applied per process basis. Therefore, if a user is executing hundreds of processes, the user may consume huge amount of resources, even if […]

Disable first time password change in AIX

Disable first time password change in AIX

 

How to disable first time password change in AIX?

Usually in AIX, if you change the password of a user, it will prompt the user to change his password when he login first time.

To disable this first time password change in AIX Server, Clear the ADMCHG […]

AIX Boot Process

AIX Boot Process

 

AIX Booting Process explained below.

Phases of the Boot Process:

1. Read Only Storage Kernel Init Phase

1. Motherboard is Checked 2. Bootlist is found 3. Boot image is read into memory 4. Initialization starts

2. Base Device Configuration Phase 1. All devices are configured with cfgmgr command

3. System […]